GitHub Advisoryadvisory · Maven

GHSA-c566-2grg-mjwg Serialization vulnerability in Apache Tapestry

CRITICAL Published 2022-02-09 Modified 2021-04-09 Official page ↗
Aliases
CVE-2020-17531
Ecosystem
Maven
Packages
org.apache.tapestry:tapestry-project
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2021-04-09

Affected packages

• Maven org.apache.tapestry:tapestry-project: >= 4.0, < 5.0.1 → fixed in 5.0.1

Description

A Java Serialization vulnerability was found in Apache Tapestry 4. Apache Tapestry 4 will attempt to deserialize the "sp" parameter even before invoking the page's validate method, leading to deserialization without authentication. Apache Tapestry 4 reached end of life in 2008 and no update to address this issue will be released. Apache Tapestry 5 versions are not vulnerable to this issue. Users of Apache Tapestry 4 should upgrade to the latest Apache Tapestry 5 version.

Related

Alias · CVE (1)

  • CVE-2020-17531 A Java Serialization vulnerability was found in Apache Tapestry 4. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References