GitHub Advisoryadvisory · Maven

GHSA-c57v-4vg5-cm2x Apache Pulsar SASL Authentication Provider observable timing discrepancy vulnerability

HIGH Published 2024-02-07 Modified 2024-07-22 Official page ↗
Aliases
CVE-2023-51437
Ecosystem
Maven
Packages
org.apache.pulsar:pulsar-broker-auth-sasl
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-200, CWE-203
Reviewed
2024-02-07

Affected packages

• Maven org.apache.pulsar:pulsar-broker-auth-sasl: < 2.11.3 → fixed in 2.11.3 • Maven org.apache.pulsar:pulsar-broker-auth-sasl: >= 3.0.0, < 3.0.2 → fixed in 3.0.2 • Maven org.apache.pulsar:pulsar-broker-auth-sasl: >= 3.1.0, < 3.1.1 → fixed in 3.1.1

Description

Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .

Related

Alias · CVE (1)

  • CVE-2023-51437 Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token… vulnerability

Weakness · CWE (2)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
  • CWE-203 Observable Discrepancy weakness

References