GitHub Advisoryadvisory · Packagist

GHSA-c5wx-6c2c-f7rm TYPO3 CMS vulnerable to Arbitrary Code Execution via Form Framework

HIGH Published 2022-12-13 Modified 2022-12-13 Official page ↗
Aliases
CVE-2022-23503
Ecosystem
Packagist
Packages
typo3/cms-core, typo3/cms
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2022-12-13

Affected packages

• Packagist typo3/cms-core: >= 8.0.0, < 8.7.49 → fixed in 8.7.49 • Packagist typo3/cms-core: >= 9.0.0, < 9.5.38 → fixed in 9.5.38 • Packagist typo3/cms-core: >= 10.0.0, < 10.4.33 → fixed in 10.4.33 • Packagist typo3/cms-core: >= 11.0.0, < 11.5.20 → fixed in 11.5.20 • Packagist typo3/cms-core: >= 12.0.0, < 12.1.1 → fixed in 12.1.1 • Packagist typo3/cms: >= 10.0.0, < 10.4.33 → fixed in 10.4.33 • Packagist typo3/cms: >= 11.0.0, < 11.5.20 → fixed in 11.5.20 • Packagist typo3/cms: >= 12.0.0, < 12.1.1 → fixed in 12.1.1

Description

Problem Due to the lack of separating user-submitted data from the internal configuration in the Form Designer backend module, it was possible to inject code instructions to be processed and executed via TypoScript as PHP code. The existence of individual TypoScript instructions for a particular form item (known as `formDefinitionOverrides`) and a valid backend user account with access to the form module are needed to exploit this vulnerability. Solution Update to TYPO3 versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1 that fix the problem described above. References • TYPO3-CORE-SA-2022-015

Related

Alias · CVE (1)

  • CVE-2022-23503 TYPO3 is an open source PHP based web content management system. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References