GitHub Advisoryadvisory · npm
GHSA-c6rp-xvqv-mwmf Cross-site Scripting in epubjs
MEDIUM
Official page ↗
- Aliases
- CVE-2021-33040
- Ecosystem
- npm
- Packages
- epubjs
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-01-19
Affected packages
• npm epubjs: < 0.3.89 → fixed in 0.3.89
Description
managers/views/iframe.js in FuturePress EPub.js before 0.3.89 allows XSS.
Related
Alias · CVE (1)
- CVE-2021-33040 managers/views/iframe.js in FuturePress EPub.js before 0.3.89 allows XSS. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-33040 advisory
- https://github.com/futurepress/epub.js/commit/ab4dd46408cce0324e1c67de4a3ba96b59e5012e web
- https://github.com/futurepress/epub.js package
- https://github.com/futurepress/epub.js/blob/5c7f21d648d9d20d44c6c365d164b16871847023/src/managers/views/iframe.js#L373 web
- https://github.com/futurepress/epub.js/compare/v0.3.88...v0.3.89 web