GitHub Advisoryadvisory · npm
GHSA-c6rx-gxqv-vr5j nemo-appium vulnerable to OS Command Injection
CRITICAL
Official page ↗
- Aliases
- CVE-2022-21129
- Ecosystem
- npm
- Packages
- nemo-appium
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77, CWE-78
- Reviewed
- 2023-02-01
Affected packages
• npm nemo-appium: < 0.0.9 → fixed in 0.0.9
Description
Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function.
Note: In order to exploit this vulnerability appium-running 0.1.3 has to be installed as one of nemo-appium dependencies.
Related
Alias · CVE (1)
- CVE-2022-21129 Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-21129 advisory
- https://github.com/paypal/nemo-appium/commit/aa271d36dd5c81baae3c43aa2616c84f0ee4195f web
- https://github.com/paypal/nemo-appium package
- https://github.com/paypal/nemo-appium/blob/master/index.js%23L27 web
- https://security.snyk.io/vuln/SNYK-JS-NEMOAPPIUM-3183747 web