GitHub Advisoryadvisory · Maven

GHSA-c6xw-hg9q-3c9f OpenNMS Cross-site Scripting vulnerability

MEDIUM Published 2023-11-17 Modified 2023-11-27 Official page ↗
Aliases
CVE-2023-40314
Ecosystem
Maven
Packages
org.opennms:opennms-webapp
Severity
Moderate
CVSS vector
CVSS:3.1/AV:A/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
Weaknesses
CWE-20, CWE-79
Reviewed
2023-11-27

Affected packages

• Maven org.opennms:opennms-webapp: < 32.0.5 → fixed in 32.0.5

Description

Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Horizon 32.0.5 or newer and Meridian 2023.1.9 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

Related

Alias · CVE (1)

  • CVE-2023-40314 Cross-site scripting in bootstrap.jsp in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References