GitHub Advisoryadvisory · Go
GHSA-c72g-53hw-82q7 OpenFGA Authorization Bypass
MEDIUM
Official page ↗
- Aliases
- CVE-2025-48371
- Ecosystem
- Go
- Packages
- github.com/openfga/openfga
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
- Weaknesses
- CWE-285
- Reviewed
- 2025-05-23
Affected packages
• Go github.com/openfga/openfga: >= 1.8.0, < 1.8.13 → fixed in 1.8.13
Description
Overview
OpenFGA v1.8.0 to v1.8.12 ( openfga-0.2.16 <= Helm chart <= openfga-0.2.31, v1.8.0 <= docker <= v.1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed.
Am I Affected?
If you are using OpenFGA v1.8.0 to v1.8.12, specifically under the following conditions, you are affected by this authorization bypass vulnerability:
• Calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset, and
• There are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset, and
• Those contextual tuples’s user field is an userset, and
• Type bound public access tuples are not assigned to the relationship
Fix
Upgrade to v1.8.13. This upgrade is backwards compatible.
Acknowledgments
OpenFGA would like to thank @udyvish for discovering this vulnerability.
Related
Alias · CVE (1)
- CVE-2025-48371 OpenFGA is an authorization/permission engine. vulnerability
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness
References
- https://github.com/openfga/openfga/security/advisories/GHSA-c72g-53hw-82q7 web
- https://nvd.nist.gov/vuln/detail/CVE-2025-48371 advisory
- https://github.com/openfga/openfga/commit/e5960d4eba92b723de8ff3a5346a07f50c1379ca web
- https://github.com/openfga/openfga package
- https://pkg.go.dev/vuln/GO-2025-3707 web