GitHub Advisoryadvisory · PyPI

GHSA-c732-xvv8-g94c Command Injection in Apache Airflow and Apache Airflow MySQL Provider

CRITICAL Published 2023-01-21 Modified 2026-10-27 Official page ↗
Aliases
CVE-2023-22884
Ecosystem
PyPI
Packages
apache-airflow, apache-airflow-providers-mysql
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-77
Reviewed
2023-01-23

Affected packages

• PyPI apache-airflow: < 2.5.1 → fixed in 2.5.1 • PyPI apache-airflow-providers-mysql: < 4.0.0 → fixed in 4.0.0

Description

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow, Apache Software Foundation Apache Airflow MySQL Provider.This issue affects Apache Airflow: before 2.5.1; Apache Airflow MySQL Provider: before 4.0.0.

Related

Alias · CVE (1)

  • CVE-2023-22884 Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache… vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References