GitHub Advisoryadvisory · Packagist

GHSA-c73w-4rcj-2622 Typo3 API Install Tool vulnerable to Cross-site Scripting

MEDIUM Published 2022-05-02 Modified 2024-02-08 Official page ↗
Aliases
CVE-2009-3636
Ecosystem
Packagist
Packages
typo3/cms-install
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2024-02-08

Affected packages

• Packagist typo3/cms-install: <= 4.0.13 (no fix yet) • Packagist typo3/cms-install: >= 4.1.0, < 4.1.13 → fixed in 4.1.13 • Packagist typo3/cms-install: >= 4.2.0, < 4.2.10 → fixed in 4.2.10 • Packagist typo3/cms-install: >= 4.3alpha1, < 4.3beta2 → fixed in 4.3beta2

Description

Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.

Related

Alias · CVE (1)

  • CVE-2009-3636 Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References