GitHub Advisoryadvisory · npm

GHSA-c75v-2vq8-878f Angular vulnerable to Cross-site Scripting

MEDIUM Published 2022-05-27 Modified 2025-11-20 Official page ↗
Aliases
CVE-2021-4231
Ecosystem
npm
Packages
@angular/core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-06-02

Affected packages

• npm @angular/core: >= 11.0.0, < 11.0.5 → fixed in 11.0.5 • npm @angular/core: >= 11.1.0-next.0, < 11.1.0-next.3 → fixed in 11.1.0-next.3 • npm @angular/core: < 10.2.5 → fixed in 10.2.5

Description

A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 10.2.5, 11.0.5 or 11.1.0-next.3 is advised to to address this issue.

Related

Alias · CVE (1)

  • CVE-2021-4231 A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References