GitHub Advisoryadvisory · npm

GHSA-c78w-2gw7-gjv3 XSS in TinyMCE

MEDIUM Published 2020-05-11 Modified 2021-01-14 Official page ↗
Aliases
CVE-2019-1010091
Ecosystem
npm
Packages
tinymce
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2020-05-11

Affected packages

• npm tinymce: < 4.9.10 → fixed in 4.9.10 • npm tinymce: >= 5.0.0, < 5.2.2 → fixed in 5.2.2

Description

Impact A cross-site scripting (XSS) vulnerability was discovered in: the core parser and `media` plugin. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.9 or lower and TinyMCE 5.2.1 or lower. Patches This vulnerability has been patched in TinyMCE 4.9.10 and 5.2.2 by improved HTML parsing and sanitization logic. Workarounds The workarounds available are: • disable the media plugin and manually sanitize CDATA content (see below) or • upgrade to either TinyMCE 4.9.10 or TinyMCE 5.2.2 Example: Manually strip CDATA elements ```js setup: function(editor) { editor.on('PreInit', function() { editor.parser.addNodeFilter('#cdata', function(nodes) { for (var i = 0; i < nodes.length; i++) { nodes[i].remove(); } }); }); } ``` Acknowledgements Tiny Technologies would like to thank Michał Bentkowski and intivesec for discovering these vulnerabilities. References https://www.tiny.cloud/docs/release-notes/release-notes522/#securityfixes For more information If you have any questions or comments about this advisory: • Open an issue in the TinyMCE repo • Email us at [email protected]

Related

Alias · CVE (1)

  • CVE-2019-1010091 tinymce 4.7.11, 4.7.12 is affected by: CWE-79: Improper Neutralization of Input During Web Page Generation. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References