GitHub Advisoryadvisory · Maven

GHSA-c825-6ph3-4h84 Apache ActiveMQ is Vulnerable to Integer Overflow or Wraparound

MEDIUM Published 2026-03-04 Modified 2026-04-10 Official page ↗
Aliases
CVE-2025-66168
Ecosystem
Maven
Packages
org.apache.activemq:apache-activemq, org.apache.activemq:activemq-all, org.apache.activemq:activemq-mqtt
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-190
Reviewed
2026-03-04

Affected packages

• Maven org.apache.activemq:apache-activemq: < 5.19.2 → fixed in 5.19.2 • Maven org.apache.activemq:apache-activemq: >= 6.0.0, < 6.1.9 → fixed in 6.1.9 • Maven org.apache.activemq:apache-activemq: >= 6.2.0, < 6.2.1 → fixed in 6.2.1 • Maven org.apache.activemq:activemq-all: < 5.19.2 → fixed in 5.19.2 • Maven org.apache.activemq:activemq-all: >= 6.0.0, < 6.1.9 → fixed in 6.1.9 • Maven org.apache.activemq:activemq-all: >= 6.2.0, < 6.2.1 → fixed in 6.2.1 • Maven org.apache.activemq:activemq-mqtt: < 5.19.2 → fixed in 5.19.2 • Maven org.apache.activemq:activemq-mqtt: >= 6.0.0, < 6.1.9 → fixed in 6.1.9 • Maven org.apache.activemq:activemq-mqtt: >= 6.2.0, < 6.2.1 → fixed in 6.2.1

Description

Apache ActiveMQ does not properly validate the remaining length field which may lead to an overflow during the decoding of malformed packets. When this integer overflow occurs, ActiveMQ may incorrectly compute the total Remaining Length and subsequently misinterpret the payload as multiple MQTT control packets which makes the broker susceptible to unexpected behavior when interacting with non-compliant clients. This behavior violates the MQTT v3.1.1 specification, which restricts Remaining Length to a maximum of 4 bytes. The scenario occurs on established connections after the authentication process. Brokers that are not enabling mqtt transport connectors are not impacted. This issue affects Apache ActiveMQ: before 5.19.2, 6.0.0 to 6.1.8, and 6.2.0 Users are recommended to upgrade to version 5.19.2, 6.1.9, or 6.2.1, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2025-66168 WARNING: Users of 6.x should upgrade to 6.2.4 or later as the fix was missed in previous 6.x releases. vulnerability

Weakness · CWE (1)

  • CWE-190 Integer Overflow or Wraparound weakness

References