GitHub Advisoryadvisory · Maven
GHSA-c87w-642h-m97h Apache Ranger has a Code Injection vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2025-59059
- Ecosystem
- Maven
- Packages
- org.apache.ranger:ranger-plugins-common
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2026-03-04
Affected packages
• Maven org.apache.ranger:ranger-plugins-common: < 2.8.0 → fixed in 2.8.0
Description
Remote Code Execution Vulnerability in NashornScriptEngineCreator is reported in Apache Ranger versions <= 2.7.0.
Users are recommended to upgrade to version 2.8.0, which fixes this issue.
Related
Alias · CVE (1)
- CVE-2025-59059 Remote Code Execution Vulnerability in NashornScriptEngineCreator is reported in Apache Ranger versions <= 2.7.0. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness