GitHub Advisoryadvisory · PyPI

GHSA-c8c8-9472-w52h Django Cross-site scripting Vulnerability

MEDIUM Published 2022-05-14 Modified 2024-09-17 Official page ↗
Aliases
CVE-2016-6186
Ecosystem
PyPI
Packages
Django
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-07-31

Affected packages

• PyPI Django: < 1.8.14 → fixed in 1.8.14 • PyPI Django: >= 1.9, < 1.9.8 → fixed in 1.9.8 • PyPI Django: >= 1.10a1, < 1.10rc1 → fixed in 1.10rc1

Description

Cross-site scripting (XSS) vulnerability in the `dismissChangeRelatedObjectPopup` function in `contrib/admin/static/admin/js/admin/RelatedObjectLookups.js` in Django before 1.8.14, 1.9.x before 1.9.8, and 1.10.x before 1.10rc1 allows remote attackers to inject arbitrary web script or HTML via vectors involving unsafe usage of Element.innerHTML.

Related

Alias · CVE (1)

  • CVE-2016-6186 Cross-site scripting (XSS) vulnerability in the dismissChangeRelatedObjectPopup function in… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References