GitHub Advisoryadvisory · Packagist
GHSA-c8f2-5h29-8j2h libconnect Extension for Typo3 Vulnerable to XSS
MEDIUM
Official page ↗
- Aliases
- CVE-2022-33157
- Ecosystem
- Packagist
- Packages
- subhh/libconnect
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-07-11
Affected packages
• Packagist subhh/libconnect: < 7.0.8 → fixed in 7.0.8
• Packagist subhh/libconnect: >= 8.0.0, < 8.1.0 → fixed in 8.1.0
Description
The libconnect extension before 7.0.8 and 8.x before 8.1.0 for TYPO3 allows XSS.
Related
Alias · CVE (1)
- CVE-2022-33157 The libconnect extension before 7.0.8 and 8.x before 8.1.0 for TYPO3 allows XSS. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness