GitHub Advisoryadvisory · Packagist
GHSA-c8v6-vxhf-wcrr Moodle has an authenticated remote code execution risk in the Moodle LMS Dropbox repository
HIGH
Official page ↗
- Aliases
- CVE-2025-3641
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2025-04-25
Affected packages
• Packagist moodle/moodle: < 4.1.18 → fixed in 4.1.18
• Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.12 → fixed in 4.3.12
• Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.8 → fixed in 4.4.8
• Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.4 → fixed in 4.5.4
Description
A flaw was found in Moodle. A remote code execution risk was identified in the Moodle LMS Dropbox repository. By default, this was only available to teachers and managers on sites with the Dropbox repository enabled.
Related
Alias · CVE (1)
- CVE-2025-3641 A flaw was found in Moodle. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-3641 advisory
- https://github.com/moodle/moodle/commit/27b839b5c60389623ca8e3496792b43a44527cd6 web
- https://access.redhat.com/security/cve/CVE-2025-3641 web
- https://bugzilla.redhat.com/show_bug.cgi?id=2359735 web
- https://github.com/moodle/moodle package
- https://moodle.org/mod/forum/discuss.php?d=467602 web