GitHub Advisoryadvisory · Maven

GHSA-c9h3-c6qj-hh7q Apache Kafka vulnerability can lead to brokers hitting OutOfMemoryException, causing Denial of Service

HIGH Published 2022-09-21 Modified 2024-05-08 Official page ↗
Aliases
CVE-2022-34917
Ecosystem
Maven
Packages
org.apache.kafka:kafka
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400, CWE-770, CWE-789
Reviewed
2022-09-21

Affected packages

• Maven org.apache.kafka:kafka: >= 2.8.0, < 2.8.2 → fixed in 2.8.2 • Maven org.apache.kafka:kafka: >= 3.0.0, < 3.0.2 → fixed in 3.0.2 • Maven org.apache.kafka:kafka: >= 3.1.0, < 3.1.2 → fixed in 3.1.2 • Maven org.apache.kafka:kafka: >= 3.2.0, < 3.2.3 → fixed in 3.2.3

Description

A security vulnerability has been identified in Apache Kafka. It affects all releases since 2.8.0. The vulnerability allows malicious unauthenticated clients to allocate large amounts of memory on brokers. This can lead to brokers hitting OutOfMemoryException and causing denial of service. Example scenarios: - Kafka cluster without authentication: Any clients able to establish a network connection to a broker can trigger the issue. - Kafka cluster with SASL authentication: Any clients able to establish a network connection to a broker, without the need for valid SASL credentials, can trigger the issue. - Kafka cluster with TLS authentication: Only clients able to successfully authenticate via TLS can trigger the issue. We advise the users to upgrade the Kafka installations to one of the 3.2.3, 3.1.2, 3.0.2, 2.8.2 versions.

Related

Alias · CVE (1)

  • CVE-2022-34917 A security vulnerability has been identified in Apache Kafka. vulnerability

Weakness · CWE (3)

  • CWE-400 Uncontrolled Resource Consumption weakness
  • CWE-770 Allocation of Resources Without Limits or Throttling weakness
  • CWE-789 Memory Allocation with Excessive Size Value weakness

References