GitHub Advisoryadvisory · Maven
GHSA-c9h6-xhg9-xxrv Improper Input Validation in Apache Qpid Broker-J
HIGH
Official page ↗
- Aliases
- CVE-2019-0200
- Ecosystem
- Maven
- Packages
- org.apache.qpid:apache-qpid-broker-j
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2020-06-16
Affected packages
• Maven org.apache.qpid:apache-qpid-broker-j: < 7.0.7 → fixed in 7.0.7
• Maven org.apache.qpid:apache-qpid-broker-j: >= 7.1.0, < 7.1.1 → fixed in 7.1.1
Description
A Denial of Service vulnerability was found in Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 which allows an unauthenticated attacker to crash the broker instance by sending specially crafted commands using AMQP protocol versions below 1.0 (AMQP 0-8, 0-9, 0-91 and 0-10). Users of Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 utilizing AMQP protocols 0-8, 0-9, 0-91, 0-10 must upgrade to Qpid Broker-J versions 7.0.7 or 7.1.1 or later.
Related
Alias · CVE (1)
- CVE-2019-0200 A Denial of Service vulnerability was found in Apache Qpid Broker-J versions 6.0.0-7.0.6 (inclusive) and 7.1.0 which allows an… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness