GitHub Advisoryadvisory · Packagist

GHSA-c9hq-g4q8-w893 Privilage Escalation in moodle

MEDIUM Published 2021-03-29 Modified 2021-03-24 Official page ↗
Aliases
CVE-2020-25701
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-863
Reviewed
2021-03-24

Affected packages

• Packagist moodle/moodle: >= 3.9.0, < 3.9.3 → fixed in 3.9.3 • Packagist moodle/moodle: >= 3.8.0, < 3.8.6 → fixed in 3.8.6 • Packagist moodle/moodle: >= 3.7.0, < 3.7.9 → fixed in 3.7.9 • Packagist moodle/moodle: >= 3.5, < 3.5.15 → fixed in 3.5.15

Description

If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would erroneously enable that enrollment method. This could lead to unintended users gaining access to the course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Related

Alias · CVE (1)

  • CVE-2020-25701 If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References