GitHub Advisoryadvisory · Packagist
GHSA-c9q3-r4rv-mjm7 Fix for arbitrary command execution in custom layout update through blocks
HIGH
Official page ↗
- Aliases
- CVE-2021-39217
- Ecosystem
- Packagist
- Packages
- openmage/magento-lts
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77
- Reviewed
- 2023-01-27
Affected packages
• Packagist openmage/magento-lts: < 19.4.22 → fixed in 19.4.22
• Packagist openmage/magento-lts: >= 20.0.0, < 20.0.19 → fixed in 20.0.19
Description
Impact
Custom Layout enabled admin users to execute arbitrary commands via block methods.
Related
Alias · CVE (1)
- CVE-2021-39217 OpenMage LTS is an e-commerce platform. vulnerability
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness
References
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-c9q3-r4rv-mjm7 web
- https://nvd.nist.gov/vuln/detail/CVE-2021-39217 advisory
- https://github.com/OpenMage/magento-lts/commit/289bd4b4f53622138e3e5c2d2cef7502d780086f web
- https://github.com/OpenMage/magento-lts package
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22 web
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19 web