GitHub Advisoryadvisory · Packagist

GHSA-cc7g-9pcj-7gwm CodeIgniter Rest Server XXE Vulnerability

CRITICAL Published 2022-05-24 Modified 2023-12-07 Official page ↗
Aliases
CVE-2015-3907
Ecosystem
Packagist
Packages
chriskacerguis/codeigniter-restserver
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-611
Reviewed
2023-07-31

Affected packages

• Packagist chriskacerguis/codeigniter-restserver: < 2.7.2 → fixed in 2.7.2

Description

CodeIgniter Rest Server (aka codeigniter-restserver) 2.7.1 allows XXE attacks.

Related

Alias · CVE (1)

  • CVE-2015-3907 CodeIgniter Rest Server (aka codeigniter-restserver) 2.7.1 allows XXE attacks. vulnerability

Weakness · CWE (1)

  • CWE-611 Improper Restriction of XML External Entity Reference weakness

References