GitHub Advisoryadvisory · Packagist

GHSA-cc94-hwj3-rf65 Moodle's login_as feature leaks information from external repositories

LOW Published 2022-05-13 Modified 2024-01-23 Official page ↗
Aliases
CVE-2013-1835
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
Weaknesses
CWE-200
Reviewed
2024-01-23

Affected packages

• Packagist moodle/moodle: >= 2.0.0, < 2.2.8 → fixed in 2.2.8 • Packagist moodle/moodle: >= 2.3.0, < 2.3.5 → fixed in 2.3.5 • Packagist moodle/moodle: >= 2.4.0, < 2.4.2 → fixed in 2.4.2

Description

Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote authenticated administrators to obtain sensitive information from the external repositories of arbitrary users by leveraging the login_as feature.

Related

Alias · CVE (1)

  • CVE-2013-1835 Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote authenticated administrators to… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References