GitHub Advisoryadvisory · Maven

GHSA-ccp5-gg58-pxfm Improper Preservation of Permissions in Apache Struts

HIGH Published 2022-05-24 Modified 2022-06-29 Official page ↗
Aliases
CVE-2019-0233
Ecosystem
Maven
Packages
org.apache.struts:struts2-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-281
Reviewed
2022-06-29

Affected packages

• Maven org.apache.struts:struts2-core: >= 2.0.0, < 2.5.22 → fixed in 2.5.22

Description

An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload.

Related

Alias · CVE (1)

  • CVE-2019-0233 An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload. vulnerability

Weakness · CWE (1)

  • CWE-281 Improper Preservation of Permissions weakness

References