GitHub Advisoryadvisory · Packagist
GHSA-cf5r-3pvm-w64w typo3-appointments vulnerable to Cross-site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2019-25094
- Ecosystem
- Packagist
- Packages
- innologi/typo3-appointments
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-01-10
Affected packages
• Packagist innologi/typo3-appointments: < 2.0.6 → fixed in 2.0.6
Description
A vulnerability, which was classified as problematic, was found in innologi appointments Extension up to 2.0.5. This affects an unknown part of the component Appointment Handler. The manipulation of the argument formfield leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 2.0.6 is able to address this issue. The name of the patch is 986d3cb34e5e086c6f04e061f600ffc5837abe7f. It is recommended to upgrade the affected component. The identifier VDB-217353 was assigned to this vulnerability.
Related
Alias · CVE (1)
- CVE-2019-25094 A vulnerability, which was classified as problematic, was found in innologi appointments Extension up to 2.0.5 on TYPO3. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-25094 advisory
- https://github.com/innologi/typo3-appointments/commit/986d3cb34e5e086c6f04e061f600ffc5837abe7f web
- https://github.com/innologi/typo3-appointments package
- https://github.com/innologi/typo3-appointments/releases/tag/2.0.6 web
- https://vuldb.com/?ctiid.217353 web
- https://vuldb.com/?id.217353 web