GitHub Advisoryadvisory · RubyGems

GHSA-cfjv-5498-mph5 XSS in Action View

MEDIUM Published 2020-09-11 Modified 2023-05-04 Official page ↗
Aliases
CVE-2020-15169
Ecosystem
RubyGems
Packages
actionview
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-09-11

Affected packages

• RubyGems actionview: < 5.2.4.4 → fixed in 5.2.4.4 • RubyGems actionview: >= 6.0.0.0, < 6.0.3.3 → fixed in 6.0.3.3

Description

There is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. Impact When an HTML-unsafe string is passed as the default for a missing translation key named `html` or ending in `_html`, the default string is incorrectly marked as HTML-safe and not escaped. Vulnerable code may look like the following examples: ```erb ``` Patches Patched Rails versions, 6.0.3.3 and 5.2.4.4, are available from the normal locations. The patches have also been applied to the `master`, `6-0-stable`, and `5-2-stable` branches on GitHub. If you track any of these branches, you should update to the latest. To aid users who aren’t able to upgrade immediately, we’ve provided patches for the two supported release series. They are in git-am format and consist of a single changeset. • 5-2-translate-helper-xss.patch — patch for the 5.2 release series • 6-0-translate-helper-xss.patch — patch for the 6.0 release series Please note that only the 5.2 and 6.0 release series are currently supported. Users of earlier, unsupported releases are advised to update as soon as possible, as we cannot provide security fixes for unsupported releases. Workarounds Impacted users who can’t upgrade to a patched Rails version can avoid this issue by manually escaping default translations with the `html_escape` helper (aliased as `h`): ```erb ```

Related

Alias · CVE (1)

  • CVE-2020-15169 In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References