GitHub Advisoryadvisory · PyPI
GHSA-cfmr-38g9-f2h7 Pillow denial of service via Crafted Block Size
HIGH
Official page ↗
- Aliases
- CVE-2014-3589
- Ecosystem
- PyPI
- Packages
- pillow
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2023-08-16
Affected packages
• PyPI pillow: < 2.3.2 → fixed in 2.3.2
• PyPI pillow: >= 2.5, < 2.5.2 → fixed in 2.5.2
Description
`PIL/IcnsImagePlugin.py` in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a denial of service via a crafted block size.
Related
Alias · CVE (1)
- CVE-2014-3589 PIL/IcnsImagePlugin.py in Python Imaging Library (PIL) and Pillow before 2.3.2 and 2.5.x before 2.5.2 allows remote attackers to cause a… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2014-3589 advisory
- https://github.com/python-pillow/Pillow/commit/205e056f8f9b06ed7b925cf8aa0874bc4aaf8a7d web
- https://github.com/python-pillow/Pillow/commit/5efeed77666bfd17708f3434b1d2daa9db1e1335 web
- https://github.com/python-pillow/Pillow/commit/d47611e6fbb808ea109366781dd76559ffb80bcd web
- https://github.com/pypa/advisory-database/tree/main/vulns/pillow/PYSEC-2014-10.yaml web
- https://github.com/python-pillow/Pillow package
- https://pypi.python.org/pypi/Pillow/2.3.2 web
- https://pypi.python.org/pypi/Pillow/2.5.2 web
- http://lists.opensuse.org/opensuse-updates/2015-04/msg00056.html web
- http://www.debian.org/security/2014/dsa-3009 web