GitHub Advisoryadvisory · Maven
GHSA-cfvw-84vq-43mx Stored XSS vulnerability in Jenkins Deployer Framework Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2227
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:deployer-framework
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-28
Affected packages
• Maven org.jenkins-ci.plugins:deployer-framework: < 1.3 → fixed in 1.3
Description
Deployer Framework Plugin is a framework plugin allowing other plugins to provide a way to deploy artifacts. Deployer Framework Plugin 1.2 and earlier does not escape the URL displayed in the build home page. This results in a stored cross-site scripting (XSS) vulnerability exploitable by users able to provide the location.
The exploitability of this vulnerability depends on the specific implementation using Deployer Framework Plugin. The Jenkins security team is not aware of any exploitable implementation.
Deployer Framework Plugin 1.3 escapes the URL.
Related
Alias · CVE (1)
- CVE-2020-2227 Jenkins Deployer Framework Plugin 1.2 and earlier does not escape the URL displayed in the build home page, resulting in a stored… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2227 advisory
- https://github.com/jenkinsci/deployer-framework-plugin/commit/8fa2e16bce85ec1b93be60102d7cfb5153876e83 web
- https://github.com/jenkinsci/deployer-framework-plugin package
- https://jenkins.io/security/advisory/2020-07-15/#SECURITY-1915 web
- http://www.openwall.com/lists/oss-security/2020/07/15/5 web