GitHub Advisoryadvisory · Maven
GHSA-cg6q-gp23-vwx8 Jenkins Crowd 2 Integration Plugin stored credentials in plain text
HIGH
Official page ↗
- Aliases
- CVE-2018-1000423
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:crowd2
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-522
- Reviewed
- 2024-01-09
Affected packages
• Maven org.jenkins-ci.plugins:crowd2: < 2.0.1 → fixed in 2.0.1
Description
An insufficiently protected credentials vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in CrowdSecurityRealm.java, CrowdConfigurationService.java that allows attackers with local file system access to obtain the credentials used to connect to Crowd 2.
Related
Alias · CVE (1)
- CVE-2018-1000423 An insufficiently protected credentials vulnerability exists in Jenkins Crowd 2 Integration Plugin 2.0.0 and earlier in… vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000423 advisory
- https://github.com/jenkinsci/crowd2-plugin/commit/580be2a0dfb38d494420901f03555092b885a85f web
- https://github.com/jenkinsci/crowd2-plugin web
- https://jenkins.io/security/advisory/2018-09-25/#SECURITY-1068 web
- http://www.securityfocus.com/bid/106532 web