GitHub Advisoryadvisory · PyPI
GHSA-cg88-rpvp-cjv5 Out of bounds write in grappler in Tensorflow
HIGH
Official page ↗
- Aliases
- CVE-2022-41902
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-cpu, tensorflow-gpu
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-125, CWE-787
- Reviewed
- 2022-11-21
Affected packages
• PyPI tensorflow: < 2.8.4 → fixed in 2.8.4
• PyPI tensorflow: >= 2.9.0, < 2.9.3 → fixed in 2.9.3
• PyPI tensorflow: >= 2.10.0, < 2.10.1 → fixed in 2.10.1
• PyPI tensorflow-cpu: < 2.8.4 → fixed in 2.8.4
• PyPI tensorflow-gpu: < 2.8.4 → fixed in 2.8.4
• PyPI tensorflow-cpu: >= 2.9.0, < 2.9.3 → fixed in 2.9.3
• PyPI tensorflow-gpu: >= 2.9.0, < 2.9.3 → fixed in 2.9.3
• PyPI tensorflow-cpu: >= 2.10.0, < 2.10.1 → fixed in 2.10.1
• PyPI tensorflow-gpu: >= 2.10.0, < 2.10.1 → fixed in 2.10.1
Description
Impact
The function MakeGrapplerFunctionItem takes arguments that determine the sizes of inputs and outputs. If the inputs given are greater than or equal to the sizes of the outputs, an out-of-bounds memory read or a crash is triggered.
Patches
We have patched the issue in GitHub commit a65411a1d69edfb16b25907ffb8f73556ce36bb7.
The fix will be included in TensorFlow 2.11.0. We will also cherrypick this commit on TensorFlow 2.10.1.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Related
Alias · CVE (1)
- CVE-2022-41902 TensorFlow is an open source platform for machine learning. vulnerability
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-cg88-rpvp-cjv5 web
- https://nvd.nist.gov/vuln/detail/CVE-2022-41902 advisory
- https://github.com/tensorflow/tensorflow/commit/a65411a1d69edfb16b25907ffb8f73556ce36bb7 web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/grappler/utils/functions.cc#L221 web