GitHub Advisoryadvisory · Maven
GHSA-cghg-jcv6-4v5m Jenkins Coverity Plugin has Insufficiently Protected Credentials
LOW
Official page ↗
- Aliases
- CVE-2018-1000104
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:coverity
- Severity
- Low
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-522
- Reviewed
- 2022-12-07
Affected packages
• Maven org.jenkins-ci.plugins:coverity: < 1.11.0 → fixed in 1.11.0
Description
A plaintext storage of a password vulnerability exists in Jenkins Coverity Plugin 1.10.0 and earlier in CIMInstance.java that allows an attacker with local file system access or control of a Jenkins administrator's web browser (e.g. malicious extension) to retrieve the configured keystore and private key passwords. The Coverity Plugin 1.11.0 integrates with Credentials Plugin to store passwords, and automatically migrates existing passwords.
Related
Alias · CVE (1)
- CVE-2018-1000104 A plaintext storage of a password vulnerability exists in Jenkins Coverity Plugin 1.10.0 and earlier in CIMInstance.java that allows an… vulnerability
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness