GitHub Advisoryadvisory · Packagist

GHSA-ch68-5r37-p7c3 Moodle cross-site scripting (XSS) vulnerability

MEDIUM Published 2022-05-13 Modified 2024-01-24 Official page ↗
Aliases
CVE-2014-0218
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-79
Reviewed
2024-01-24

Affected packages

• Packagist moodle/moodle: < 2.4.10 → fixed in 2.4.10 • Packagist moodle/moodle: >= 2.5.0, < 2.5.6 → fixed in 2.5.6 • Packagist moodle/moodle: >= 2.6.0, < 2.6.3 → fixed in 2.6.3

Description

Cross-site scripting (XSS) vulnerability in the URL downloader repository in repository/url/lib.php in Moodle through 2.3.11, 2.4.x before 2.4.10, 2.5.x before 2.5.6, and 2.6.x before 2.6.3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2014-0218 Cross-site scripting (XSS) vulnerability in the URL downloader repository in repository/url/lib.php in Moodle through 2.3.11, 2.4.x before… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References