GitHub Advisoryadvisory · Packagist

GHSA-chgc-rqjr-46gg simplesamlphp-module-openidprovider Cross Site Scripting vulnerability

MEDIUM Published 2023-01-17 Modified 2024-03-01 Official page ↗
Aliases
CVE-2010-10008
Ecosystem
Packagist
Packages
simplesamlphp/simplesamlphp-module-openidprovider
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-01-25

Affected packages

• Packagist simplesamlphp/simplesamlphp-module-openidprovider: < 0.9.0 → fixed in 0.9.0

Description

A vulnerability was found in simplesamlphp simplesamlphp-module-openidprovider up to 0.8.x. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file templates/trust.tpl.php. The manipulation of the argument StateID leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The name of the patch is 8365d48c863cf06ccf1465cc0a161cefae29d69d. It is recommended to upgrade the affected component. The identifier VDB-218473 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Related

Alias · CVE (1)

  • CVE-2010-10008 ** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in simplesamlphp simplesamlphp-module-openidprovider up to 0.8.x. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References