GitHub Advisoryadvisory · Packagist

GHSA-cj7w-pm77-hvg6 Magento XML Injection vulnerability in the Widgets Module

CRITICAL Published 2022-08-17 Modified 2024-01-11 Official page ↗
Aliases
CVE-2022-34253
Ecosystem
Packagist
Packages
magento/community-edition
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-91
Reviewed
2024-01-11

Affected packages

• Packagist magento/community-edition: < 2.3.7-p4 → fixed in 2.3.7-p4 • Packagist magento/community-edition: >= 2.4.4, < 2.4.5 → fixed in 2.4.5 • Packagist magento/community-edition: >= 2.4.0, < 2.4.3-p3 → fixed in 2.4.3-p3

Description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an XML Injection vulnerability in the Widgets Module. An attacker with admin privileges can trigger a specially crafted script to achieve remote code execution. Exploitation of this issue does not require user interaction.

Related

Alias · CVE (1)

  • CVE-2022-34253 Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an XML Injection… vulnerability

Weakness · CWE (1)

  • CWE-91 XML Injection weakness

References