GitHub Advisoryadvisory · npm
GHSA-cj88-88mr-972w glob-parent 6.0.0 vulnerable to Regular Expression Denial of Service
HIGH
Official page ↗
- Aliases
- CVE-2021-35065
- Ecosystem
- npm
- Packages
- glob-parent
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-1333, CWE-400
- Reviewed
- 2022-07-18
Affected packages
• npm glob-parent: >= 6.0.0, < 6.0.1 → fixed in 6.0.1
Description
glob-parent 6.0.0 is vulnerable to Regular Expression Denial of Service (ReDoS). This issue is fixed in version 6.0.1.
This vulnerability is separate from GHSA-ww39-953v-wcq6.
Related
Alias · CVE (1)
- CVE-2021-35065 The glob-parent package before 6.0.1 for Node.js allows ReDoS (regular expression denial of service) attacks against the enclosure regular… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-35065 advisory
- https://github.com/opensearch-project/OpenSearch-Dashboards/issues/1103 web
- https://github.com/gulpjs/glob-parent/pull/49 web
- https://github.com/gulpjs/glob-parent/commit/32f6d52663b7addac38d0dff570d8127edf03f47 web
- https://github.com/gulpjs/glob-parent/commit/3e9f04a3b4349db7e1962d87c9a7398cda51f339 web
- https://github.com/gulpjs/glob-parent package
- https://github.com/gulpjs/glob-parent/releases/tag/v6.0.1 web
- https://security.netapp.com/advisory/ntap-20230214-0010 web
- https://security.snyk.io/vuln/SNYK-JS-GLOBPARENT-1314294 web
- https://www.mend.io/vulnerability-database/CVE-2021-35065 web