GitHub Advisoryadvisory · PyPI
GHSA-cjg3-q24h-9qwf Plone Privilege Escallation
HIGH
Official page ↗
- Aliases
- CVE-2020-7938
- Ecosystem
- PyPI
- Packages
- plone.restapi, Plone
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269
- Reviewed
- 2023-07-13
Affected packages
• PyPI plone.restapi: < 6.2.1 → fixed in 6.2.1
• PyPI Plone: >= 5.2.0, < 5.2.2 → fixed in 5.2.2
Description
plone.restapi in Plone 5.2.0 through 5.2.1 allows users with a certain privilege level to escalate their privileges up to the highest level.
Related
Alias · CVE (1)
- CVE-2020-7938 plone.restapi in Plone 5.2.0 through 5.2.1 allows users with a certain privilege level to escalate their privileges up to the highest level. vulnerability
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-7938 advisory
- https://github.com/plone/plone.restapi/issues/857 web
- https://github.com/plone/plone.restapi/pull/859 web
- https://github.com/pypa/advisory-database/tree/main/vulns/plone/PYSEC-2020-87.yaml web
- https://plone.org/security/hotfix/20200121 web
- https://plone.org/security/hotfix/20200121/privilege-escalation-when-plone-restapi-is-installed web
- https://www.openwall.com/lists/oss-security/2020/01/22/1 web
- http://www.openwall.com/lists/oss-security/2020/01/24/1 web