GitHub Advisoryadvisory · Go

GHSA-cjjc-xp8v-855w Helm uses crypto package vulnerable to panic from malformed X.509 certificate

HIGH Published 2021-06-23 Modified 2024-05-31 Official page ↗
Aliases
CVE-2020-7919
Ecosystem
Go
Packages
github.com/helm/helm, helm.sh/helm/v3, golang.org/x/crypto
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-295
Reviewed
2021-06-18

Affected packages

• Go github.com/helm/helm: >= 2.0.0, < 2.16.8 → fixed in 2.16.8 • Go helm.sh/helm/v3: >= 3.0.0, < 3.1.0 → fixed in 3.1.0 • Go golang.org/x/crypto: < 0.0.0-20200124225646-8b5121be2f68 → fixed in 0.0.0-20200124225646-8b5121be2f68

Description

The Helm core maintainers have identified a high severity security vulnerability in Go's `crypto` package affecting all versions prior to Helm 2.16.8 and Helm 3.1.0. Thanks to @ravin9249 for identifying the vulnerability. Impact Go before 1.12.16 and 1.13.x before 1.13.7 (and the `crypto/cryptobyte` package before 0.0.0-20200124225646-8b5121be2f68 for Go) allows attacks on clients resulting in a panic via a malformed X.509 certificate. This may allow a remote attacker to cause a denial of service. Patches A patch to compile Helm against Go 1.14.4 has been provided for Helm 2 and is available in Helm 2.16.8. Helm 3.1.0 and newer are compiled against Go 1.13.7+. Workarounds No workaround is available. Users are urged to upgrade. References • https://nvd.nist.gov/vuln/detail/CVE-2020-7919 • https://github.com/helm/helm/pull/8288 For more information If you have any questions or comments about this advisory: • Open an issue in the Helm repository • For security-specific issues, email us at

Related

Alias · CVE (1)

  • CVE-2020-7919 Go before 1.12.16 and 1.13.x before 1.13.7 (and the crypto/cryptobyte package before 0.0.0-20200124225646-8b5121be2f68 for Go) allows… vulnerability

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References