GitHub Advisoryadvisory · npm
GHSA-cm22-4g7w-348p serve-static vulnerable to template injection that can lead to XSS
LOW
Official page ↗
- Aliases
- CVE-2024-43800
- Ecosystem
- npm
- Packages
- serve-static
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-79
- Reviewed
- 2024-09-10
Affected packages
• npm serve-static: < 1.16.0 → fixed in 1.16.0
• npm serve-static: >= 2.0.0, < 2.1.0 → fixed in 2.1.0
Description
Impact
passing untrusted user input - even after sanitizing it - to `redirect()` may execute untrusted code
Patches
this issue is patched in serve-static 1.16.0
Workarounds
users are encouraged to upgrade to the patched version of express, but otherwise can workaround this issue by making sure any untrusted inputs are safe, ideally by validating them against an explicit allowlist
Details
successful exploitation of this vector requires the following:
1. The attacker MUST control the input to response.redirect()
1. express MUST NOT redirect before the template appears
1. the browser MUST NOT complete redirection before:
1. the user MUST click on the link in the template
Related
Alias · CVE (1)
- CVE-2024-43800 serve-static serves static files. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/expressjs/serve-static/security/advisories/GHSA-cm22-4g7w-348p web
- https://nvd.nist.gov/vuln/detail/CVE-2024-43800 advisory
- https://github.com/expressjs/serve-static/commit/0c11fad159898cdc69fd9ab63269b72468ecaf6b web
- https://github.com/expressjs/serve-static/commit/ce730896fddce1588111d9ef6fdf20896de5c6fa web
- https://github.com/expressjs/serve-static package