GitHub Advisoryadvisory · PyPI
GHSA-cmc7-mfmr-xqrx Logic error in authentication in proxy.py
HIGH
Official page ↗
- Aliases
- CVE-2021-3116
- Ecosystem
- PyPI
- Packages
- proxy.py
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-287, CWE-480, CWE-697
- Reviewed
- 2021-04-06
Affected packages
• PyPI proxy.py: < 2.3.1 → fixed in 2.3.1
Description
before_upstream_connection in AuthPlugin in http/proxy/auth.py in proxy.py before 2.3.1 accepts incorrect Proxy-Authorization header data because of a boolean confusion (and versus or).
Related
Alias · CVE (1)
- CVE-2021-3116 before_upstream_connection in AuthPlugin in http/proxy/auth.py in proxy.py before 2.3.1 accepts incorrect Proxy-Authorization header data… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-3116 advisory
- https://github.com/abhinavsingh/proxy.py/pull/482 web
- https://github.com/abhinavsingh/proxy.py/pull/482/commits/9b00093288237f5073c403f2c4f62acfdfa8ed46 web
- https://github.com/abhinavsingh/proxy.py/commit/bff171ec26d826ae1d22d2466eaf9d8bdbf059d3 web
- https://cardaci.xyz/advisories/2021/01/10/proxy.py-2.3.0-broken-basic-authentication web
- https://github.com/abhinavsingh/proxy.py package
- https://github.com/advisories/GHSA-cmc7-mfmr-xqrx advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/proxy-py/PYSEC-2021-46.yaml web
- https://pypi.org/project/proxy.py/2.3.1/#history web