GitHub Advisoryadvisory · Packagist

GHSA-cmfh-mpmf-fmq4 Connect-CMS has DOM-based Cross-Site Scripting (XSS) in the Cabinet Plugin List View

HIGH Published 2026-03-23 Modified 2026-03-25 Official page ↗
Aliases
CVE-2026-32277
Ecosystem
Packagist
Packages
opensource-workshop/connect-cms
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
Weaknesses
CWE-79
Reviewed
2026-03-23

Affected packages

• Packagist opensource-workshop/connect-cms: >= 1.35.0, < 1.41.1 → fixed in 1.41.1 • Packagist opensource-workshop/connect-cms: >= 2.35.0, < 2.41.1 → fixed in 2.41.1

Description

Security Advisory — Cabinet Plugin (DOM-based XSS) Summary A DOM-based Cross-Site Scripting (XSS) issue exists in the Cabinet Plugin list view. Affected Versions • 1.x series: >= 1.35.0, = 2.35.0, <= 2.41.0 Patched Versions • 1.41.1 • 2.41.1 Description In the Cabinet Plugin list view, DOM-based Cross-Site Scripting (XSS) could occur due to how saved names were rendered. If exploited, arbitrary script could run in the victim's browser, which may lead to unauthorized actions or information theft. Exploitation requires that the attacker be able to reach the affected functionality as an authenticated user. Users affected by this vulnerability should update to a fixed version. Solution Update to the fixed version. For the 1.x series, update to 1.41.1 or later. For the 2.x series, update to 2.41.1 or later. Credits OpenSource WorkShop thanks Sho Odagiri (小田切 祥) of GMO Cybersecurity by Ierae, Inc. for reporting this vulnerability.

Related

Alias · CVE (1)

  • CVE-2026-32277 Connect-CMS is a content management system. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References