GitHub Advisoryadvisory · Maven
GHSA-cmgm-q8hf-p7jc XXE vulnerability in Jenkins Code Coverage API Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2172
- Ecosystem
- Maven
- Packages
- io.jenkins.plugins:code-coverage-api
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-611, CWE-776
- Reviewed
- 2022-12-20
Affected packages
• Maven io.jenkins.plugins:code-coverage-api: < 1.1.5 → fixed in 1.1.5
Description
Code Coverage API Plugin 1.1.4 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. This allows a user able to control the input files for the \"Publish Coverage Report\" post-build step to have Jenkins parse a crafted file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery.
Code Coverage API Plugin 1.1.5 disables external entity resolution for its XML parser.
Related
Alias · CVE (1)
- CVE-2020-2172 Jenkins Code Coverage API Plugin 1.1.4 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2172 advisory
- https://github.com/jenkinsci/code-coverage-api-plugin/commit/f0ef84c25f7bc4de4e722e994de57d238225834c web
- https://github.com/jenkinsci/code-coverage-api-plugin package
- https://jenkins.io/security/advisory/2020-04-07/#SECURITY-1699 web
- http://www.openwall.com/lists/oss-security/2020/04/07/3 web