GitHub Advisoryadvisory · PyPI
GHSA-cmjc-52fg-9f7j Apache Superset vulnerable to Exposure of Sensitive Information
MEDIUM
Official page ↗
- Aliases
- CVE-2023-30776
- Ecosystem
- PyPI
- Packages
- apache-superset
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
- Reviewed
- 2023-07-06
Affected packages
• PyPI apache-superset: >= 1.3.0, < 2.1.0 → fixed in 2.1.0
Description
An authenticated user with specific data permissions could access database connections stored passwords by requesting a specific REST API. This issue affects Apache Superset version 1.3.0 up to 2.0.1.
Related
Alias · CVE (1)
- CVE-2023-30776 An authenticated user with specific data permissions could access database connections stored passwords by requesting a specific REST API. vulnerability
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness