GitHub Advisoryadvisory · Packagist

GHSA-cmmh-8mwp-gq5p Drupal Cross Site Scripting (XSS) vulnerability

MEDIUM Published 2022-05-24 Modified 2024-04-23 Official page ↗
Aliases
CVE-2019-6341
Ecosystem
Packagist
Packages
drupal/core, drupal/drupal
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-04-23

Affected packages

• Packagist drupal/core: >= 7.0.0, < 7.65.0 → fixed in 7.65.0 • Packagist drupal/core: >= 8.0.0, < 8.5.14 → fixed in 8.5.14 • Packagist drupal/core: >= 8.6.0, < 8.6.13 → fixed in 8.6.13 • Packagist drupal/drupal: >= 7.0.0, < 7.65.0 → fixed in 7.65.0 • Packagist drupal/drupal: >= 8.0.0, < 8.5.14 → fixed in 8.5.14 • Packagist drupal/drupal: >= 8.6.0, < 8.6.13 → fixed in 8.6.13

Description

In Drupal 7 versions prior to 7.65; Drupal 8.6 versions prior to 8.6.13;Drupal 8.5 versions prior to 8.5.14. Under certain circumstances the File `module/subsystem` allows a malicious user to upload a file that can trigger a cross-site scripting (XSS) vulnerability.

Related

Alias · CVE (1)

  • CVE-2019-6341 In Drupal 7 versions prior to 7.65; Drupal 8.6 versions prior to 8.6.13;Drupal 8.5 versions prior to 8.5.14. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References