GitHub Advisoryadvisory · Packagist

GHSA-cp39-43xr-2wrp Moodle XSS Vulnerability

LOW Published 2022-05-13 Modified 2024-01-25 Official page ↗
Aliases
CVE-2015-2269
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
Weaknesses
CWE-79
Reviewed
2023-08-01

Affected packages

• Packagist moodle/moodle: <= 2.5.9 (no fix yet) • Packagist moodle/moodle: >= 2.6.0, < 2.6.9 → fixed in 2.6.9 • Packagist moodle/moodle: >= 2.7.0, < 2.7.6 → fixed in 2.7.6 • Packagist moodle/moodle: >= 2.8.0, < 2.8.4 → fixed in 2.8.4

Description

Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) alt or (2) title attribute in an IMG element.

Related

Alias · CVE (1)

  • CVE-2015-2269 Multiple cross-site scripting (XSS) vulnerabilities in lib/javascript-static.js in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References