GitHub Advisoryadvisory · npm

GHSA-cph6-524f-3hgr Directus Vulnerable to Information Leakage in Existing Collections

MEDIUM Published 2025-11-13 Modified 2025-11-15 Official page ↗
Aliases
CVE-2025-64749
Ecosystem
npm
Packages
directus, @directus/api
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-203, CWE-209
Reviewed
2025-11-13

Affected packages

• npm directus: < 11.13.0 → fixed in 11.13.0 • npm @directus/api: < 32.0.0 → fixed in 32.0.0

Description

Summary: An observable difference in error messaging was found in the Directus REST API. The `/items/{collection}` API returns different error messages for these two cases: 1. A user tries to access an existing collection which they are not authorized to access. 2. A user tries to access a non-existing collection. The two differing error messages leak the existence of collections to users which are not authorized to access these collections. Details: The following response returns an error message, when requesting a collection the user is not authorized to access. ``` GET /items/no-access { "errors": [ { "message": "You don't have permission to access collection \"no-access\" or it does not exist. Queried in root.", "extensions": { "reason": "You don't have permission to access collection \"no-access\" or it does not exist. Queried in root.", "code": "FORBIDDEN" } } ] } ``` The following response returns a different error message when requesting a collection which does not exist. ``` GET /items/does-not-exist { "errors": [ { "message": "You don't have permission to access this.", "extensions": { "code": "FORBIDDEN" } } ] } ``` Impact: The difference in errors between non-existent collections and collections blocked by permissions leak the existence of a collection to a user which is not authorized to access this object. Credit: Sebastian Krause - Hackmanit GmbH

Related

Alias · CVE (1)

  • CVE-2025-64749 Directus is a real-time API and App dashboard for managing SQL database content. vulnerability

Weakness · CWE (2)

  • CWE-203 Observable Discrepancy weakness
  • CWE-209 Generation of Error Message Containing Sensitive Information weakness

References