GitHub Advisoryadvisory · Packagist

GHSA-cpm7-mv33-jwf8 Moodle's AJAX section delete does not respect course_can_delete_section()

MEDIUM Published 2025-04-25 Modified 2025-04-25 Official page ↗
Aliases
CVE-2025-3644
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-863
Reviewed
2025-04-25

Affected packages

• Packagist moodle/moodle: < 4.1.18 → fixed in 4.1.18 • Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.12 → fixed in 4.3.12 • Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.8 → fixed in 4.4.8 • Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.4 → fixed in 4.5.4

Description

A flaw was found in Moodle. Additional checks were required to prevent users from deleting course sections they did not have permission to modify.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References