GitHub Advisoryadvisory · PyPI

GHSA-cpv4-ggrr-7j9v Rasa Allows Remote Code Execution via Remote Model Loading

CRITICAL Published 2025-01-14 Modified 2025-01-14 Official page ↗
Aliases
CVE-2024-49375
Ecosystem
PyPI
Packages
rasa-pro, rasa
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-502, CWE-94
Reviewed
2025-01-14

Affected packages

• PyPI rasa-pro: >= 3.10.0, < 3.10.12 → fixed in 3.10.12 • PyPI rasa-pro: >= 3.9.0, < 3.9.16 → fixed in 3.9.16 • PyPI rasa-pro: < 3.8.18 → fixed in 3.8.18 • PyPI rasa: < 3.6.21 → fixed in 3.6.21

Description

Vulnerability A vulnerability has been identified in Rasa Pro and Rasa Open Source that enables an attacker who has the ability to load a maliciously crafted model remotely into a Rasa instance to achieve Remote Code Execution. The prerequisites for this are: • The HTTP API must be enabled on the Rasa instance eg with `--enable-api`. This is not the default configuration. • For unauthenticated RCE to be exploitable, the user must not have configured any authentication or other security controls recommended in our documentation. • For authenticated RCE, the attacker must posses a valid authentication token or JWT to interact with the Rasa API. Fix We encourage you to upgrade to a version of Rasa that includes a fix. These are: • Rasa Pro 3.8.18, 3.9.16, 3.10.12 • Rasa Open Source 3.6.21 Once you have upgraded your Rasa Pro or Open Source installation, you will need to retrain your model using the fixed version of Rasa Pro or Open Source. If you have a custom component that inherits from one of the components listed below and modified the persist or load method, make sure to update your code. Please contact us in case you encounter any problems. Affected components: • `CountVectorFeaturizer` • `LexicalSyntacticFeaturizer` • `LogisticRegressionClassifier` • `SklearnIntentClassifier` • `DIETClassifier` • `CRFEntityExtractor` • `TrackerFeaturizer` • `TEDPolicy` • `UnexpectedIntentTEDPolicy` If you are unable to upgrade immediately, please follow our mitigation advice below. Mitigation Advice • The unauthenticated RCE can be mitigated by ensuring that you enable authentication for the Rasa HTTP API if this is enabled. This means that in addition to passing `--enable-api` to Rasa, you should also pass an authentication configuration as described in our documentation here. • The authenticated RCE can be mitigated by: • Ensuring that you only load models from trusted sources such as your own CI pipelines. You can check file hashes for model archives to confirm that a model has not been tampered with between training and use. • Confirming that you have sufficient access controls and utilize the principle of least privilege to control who in your organization has the ability to interact with the Rasa API even with authentication enabled. Future Releases As an additional security step, a future release of Rasa Pro will remove the ability to enable the API without any authentication method enabled. Credit Rasa would like to thank Julian Scheid from Deutsche Telekom Security GmbH for responsible disclosure of this vulnerability.

Related

Alias · CVE (1)

  • CVE-2024-49375 Open source machine learning framework. vulnerability

Weakness · CWE (2)

  • CWE-502 Deserialization of Untrusted Data weakness
  • CWE-94 Improper Control of Generation of Code weakness

References