GitHub Advisoryadvisory · Packagist

GHSA-cpv8-6xgr-rmf6 Dolibarr Cross-site Scripting vulnerability

CRITICAL Published 2021-08-30 Modified 2022-08-10 Official page ↗
Aliases
CVE-2021-25955
Ecosystem
Packagist
Packages
dolibarr/dolibarr
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-79
Reviewed
2021-08-26

Affected packages

• Packagist dolibarr/dolibarr: >= 2.8.1, < 14.0.0 → fixed in 14.0.0

Description

In `Dolibarr ERP CRM`, WYSIWYG Editor module, v2.8.1 to v13.0.2 are affected by a stored XSS vulnerability that allows low privileged application users to store malicious scripts in the `Private Note` field at `/adherents/note.php?id=1` endpoint. These scripts are executed in a victim’s browser when they open the page containing the vulnerable field. In the worst case, the victim who inadvertently triggers the attack is a highly privileged administrator. The injected scripts can extract the Session ID, which can lead to full Account takeover of the admin and due to other vulnerability (Improper Access Control on Private notes) a low privileged user can update the private notes which could lead to privilege escalation.

Related

Alias · CVE (1)

  • CVE-2021-25955 In “Dolibarr ERP CRM”, WYSIWYG Editor module, v2.8.1 to v13.0.2 are affected by a stored XSS vulnerability that allows low privileged… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References