GitHub Advisoryadvisory · PyPI
GHSA-cq76-mxrc-vchh Crash in `tf.math.segment_*` operations
MEDIUM
Official page ↗
- Aliases
- CVE-2021-41195
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-cpu, tensorflow-gpu
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-190
- Reviewed
- 2021-11-08
Affected packages
• PyPI tensorflow: >= 2.6.0, < 2.6.1 → fixed in 2.6.1
• PyPI tensorflow: >= 2.5.0, < 2.5.2 → fixed in 2.5.2
• PyPI tensorflow: < 2.4.4 → fixed in 2.4.4
• PyPI tensorflow-cpu: >= 2.6.0, < 2.6.1 → fixed in 2.6.1
• PyPI tensorflow-cpu: >= 2.5.0, < 2.5.2 → fixed in 2.5.2
• PyPI tensorflow-cpu: < 2.4.4 → fixed in 2.4.4
• PyPI tensorflow-gpu: >= 2.6.0, < 2.6.1 → fixed in 2.6.1
• PyPI tensorflow-gpu: >= 2.5.0, < 2.5.2 → fixed in 2.5.2
• PyPI tensorflow-gpu: < 2.4.4 → fixed in 2.4.4
Description
Impact
The implementation of `tf.math.segment_*` operations results in a `CHECK`-fail related abort (and denial of service) if a segment id in `segment_ids` is large.
```python
import tensorflow as tf
tf.math.segment_max(data=np.ones((1,10,1)), segment_ids=[1676240524292489355])
tf.math.segment_min(data=np.ones((1,10,1)), segment_ids=[1676240524292489355])
tf.math.segment_mean(data=np.ones((1,10,1)), segment_ids=[1676240524292489355])
tf.math.segment_sum(data=np.ones((1,10,1)), segment_ids=[1676240524292489355])
tf.math.segment_prod(data=np.ones((1,10,1)), segment_ids=[1676240524292489355])
```
This is similar to CVE-2021-29584 (and similar other reported vulnerabilities in TensorFlow, localized to specific APIs): the implementation (both on CPU and GPU) computes the output shape using `AddDim`. However, if the number of elements in the tensor overflows an `int64_t` value, `AddDim` results in a `CHECK` failure which provokes a `std::abort`. Instead, code should use `AddDimWithStatus`.
Patches
We have patched the issue in GitHub commit e9c81c1e1a9cd8dd31f4e83676cab61b60658429 (merging #51733).
The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported externally via a GitHub issue.
Related
Alias · CVE (1)
- CVE-2021-41195 TensorFlow is an open source platform for machine learning. vulnerability
Weakness · CWE (1)
- CWE-190 Integer Overflow or Wraparound weakness
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-cq76-mxrc-vchh web
- https://nvd.nist.gov/vuln/detail/CVE-2021-41195 advisory
- https://github.com/tensorflow/tensorflow/issues/46888 web
- https://github.com/tensorflow/tensorflow/pull/51733 web
- https://github.com/tensorflow/tensorflow/commit/e9c81c1e1a9cd8dd31f4e83676cab61b60658429 web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-844.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-846.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-842.yaml web
- https://github.com/tensorflow/tensorflow package