GitHub Advisoryadvisory · PyPI

GHSA-cq94-qf6q-mf2h Pysaml2 improperly initializes encryption vector

MEDIUM Published 2018-07-16 Modified 2024-10-14 Official page ↗
Aliases
CVE-2017-1000246
Ecosystem
PyPI
Packages
pysaml2
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-330
Reviewed
2020-06-16

Affected packages

• PyPI pysaml2: < 4.6.0 → fixed in 4.6.0

Description

Python package pysaml2 version 4.5.0 and earlier reuses the initialization vector across encryptions in the IDP server, resulting in weak encryption of data.

Related

Alias · CVE (1)

  • CVE-2017-1000246 Python package pysaml2 version 4.4.0 and earlier reuses the initialization vector across encryptions in the IDP server, resulting in weak… vulnerability

Weakness · CWE (1)

  • CWE-330 Use of Insufficiently Random Values weakness

References