GitHub Advisoryadvisory · PyPI

GHSA-cqff-fx2x-p86v botframework-connector vulnerable to Improper Authentication

HIGH Published 2021-03-08 Modified 2024-09-13 Official page ↗
Ecosystem
PyPI
Packages
botframework-connector
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
Weaknesses
CWE-287
Reviewed
2021-03-08

Affected packages

• PyPI botframework-connector: >= 4.7.0, < 4.7.2 → fixed in 4.7.2 • PyPI botframework-connector: >= 4.8.0, < 4.8.1 → fixed in 4.8.1 • PyPI botframework-connector: >= 4.9.0, < 4.9.3 → fixed in 4.9.3 • PyPI botframework-connector: >= 4.10.0, < 4.10.1 → fixed in 4.10.1

Description

Impact A maliciously crafted claim may be incorrectly authenticated by the bot. Impacts bots that are not configured to be used as a Skill. This vulnerability requires an attacker to have internal knowledge of the bot. Patches The problem has been patched in all affected versions. Please see the list of patched versions for the most appropiate one for your individual case. Workarounds Users who do not wish or are not able to upgrade can add an authentication configuration containing ClaimsValidator, which throws an exception if Claims are Skill Claims. For detailed instructions, see the link in the References section. For more information If you have any questions or comments about this advisory: • Open an issue in Microsoft Bot Builder SDK • Email us at [email protected]

Related

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References